Interruption in email delivery

Incident Report for pdk.io

Resolved

Monitoring of outgoing emails from pdk.io show that emails are flowing again.
Posted Feb 21, 2023 - 16:07 MST

Investigating

Our email provider mailgun.com is currently experiencing intermittent service interruptions that are affecting the transmission of email invites, mobile credentials and event notifications from pdk.io. We are monitoring the situation and anticipate a full restoration of email capability soon.
Posted Feb 21, 2023 - 12:54 MST
This incident affected: PDK.IO management.