Slow loading pages on PDK.IO

Incident Report for pdk.io

Resolved

We have identified the issue causing the slow page loading and it is now resolved.

Thank you for your patience!
Posted May 12, 2025 - 12:52 MDT

Investigating

This morning, we are experiencing slow-loading pages on PDK.IO. The PDK Engineering team is investigating the issue, and we anticipate a resolution soon.

Please note that this does not affect local access control operations at your site.
Posted May 12, 2025 - 12:38 MDT
This incident affected: PDK.IO management.