Slow Response Times Navigating pdk.io

Incident Report for pdk.io

Resolved

We have confirmed that our remediation steps have resolved the issue.

We appreciate your patience while our teams investigated and resolved this issue.
Posted May 13, 2026 - 11:03 MDT

Monitoring

We have identified an issue causing slowness on pdk.io and have taken remediation steps to alleviate the delays.  We will continue to monitor the situation and post further updates as necessary.
Posted May 13, 2026 - 09:27 MDT

Investigating

We are investigating reports of slowness navigating various parts of PDK.IO. While slowness is occasionally occurring, PDK.IO remains fully operational as well as all access control functions on site
Posted May 13, 2026 - 09:03 MDT
This incident affected: PDK.IO management.